Intermittent Dashboard and Sidebar Latency or Outage
Incident Report for Cirrus Insight
Resolved
This incident has been resolved.
Posted Oct 11, 2023 - 19:26 UTC
Monitoring
This issue has been identified and corrected. We will continue to monitor further.

Apologies for any inconvenience this may have caused.
Posted Oct 11, 2023 - 16:09 UTC
Investigating
We are currently experiencing issues with the Cirrus Insight sidebar and dashboard. We're investigating the outage and will provide updates accordingly
Posted Oct 11, 2023 - 15:54 UTC
This incident affected: Cirrus Insight Gmail, Cirrus Insight Outlook, Account Management Dashboard, and cirrusinsight.com.