Slow Sync Process

Incident Report for Cirrus Insight

Resolved

This issue has been resolved. Thank you for your patience.
Posted Jan 14, 2026 - 13:16 UTC

Investigating

We're currently investigating why some users are seeing slow calendar and email sync response times on our current product. The syncs do not fail, they're just slow to run the required process. Updates to follow as they become available.
Posted Jan 13, 2026 - 14:52 UTC
This incident affected: Email Sync and Calendar Sync.