A fix has been deployed and we're monitoring the situation.
Posted Apr 29, 2025 - 00:09 UTC
Identified
This issue has been identified and a fix is being deployed to address the Bad Gateway errors.
Posted Apr 28, 2025 - 15:19 UTC
Investigating
A subset of Cirrus Insight 19 users are seeing link tracking returning a Bad Gateway error when a recipient selects a tracked link. Temporarily disabling email tracking allows links to return data.
Our Engineering teams are working diligently to resolve this issue and will provide updates as they become available.