Microsoft and Microsoft Azure Outage

Incident Report for Cirrus Insight

Resolved

At this time, all service outages affecting Microsoft and Microsoft Azure have been resolved.

If you continue to experience issues or have any questions, please reach out to customersupport@cirrusinsight.com.

We appreciate your patience during this disruption.
Posted Oct 30, 2025 - 12:14 UTC

Investigating

At this time, Microsoft and Microsoft Azure are experiencing nationwide service outages. This is intermittently impacting some Cirrus Insight services. Microsoft has not provided an estimated time for resolution yet. We're actively monitoring the situation and will send updates as they become available.

Please reach out to customersupport@cirrusinsight.com with any questions.
Posted Oct 29, 2025 - 18:14 UTC
This incident affected: Cirrus Insight Gmail, Cirrus Insight Outlook, Account Management Dashboard, Email Sync, Calendar Sync, Email Tracking, Book Meeting, Personal Scheduling Page, Cirrus Insight for Google Calendar Tab, Flight Plans, Attach.io, cirrusinsight.com, and Buyer Signals.