AWS Issues With Chat and 19 Product

Incident Report for Cirrus Insight

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 12:19 UTC

Investigating

AWS has reported increased error rates and latencies across multiple services in its US-East-1 region today. As a result, we're seeing intermittent issues with our Cirrus Insight 19 application.

This is also disrupting our ability to triage incoming chat support requests. In the event that you encounter any issues connecting with our support team, it's recommended to send an email to customersupport@cirrusinsight.com stating the issue you may be experiencing.
Posted Oct 20, 2025 - 15:01 UTC
This incident affected: Cirrus Insight Gmail, Cirrus Insight Outlook, Account Management Dashboard, Email Sync, Calendar Sync, Email Tracking, Book Meeting, Personal Scheduling Page, Cirrus Insight for Google Calendar Tab, Flight Plans, Attach.io, cirrusinsight.com, and Buyer Signals.