Cirrus Insight Book Meeting and Personal Scheduling Page Issues
Incident Report for Cirrus Insight
Resolved
This incident has been resolved. Thank you for your patience in this regard.
Posted Mar 23, 2020 - 19:01 UTC
Monitoring
The Cirrus Insight Engineering team has established the root cause of the ongoing calendaring and error issues, which a subset of users were experiencing. These issues have been addressed and we're seeing stable response times, as well as no further errors.

We will continue to monitor the results and update you as required.
Posted Mar 23, 2020 - 15:22 UTC
Update
We are continuing to investigate this issue.
Posted Mar 23, 2020 - 14:40 UTC
Investigating
We're currently receiving reports that our Book Meeting application and Personal Scheduling Pages seem to be experiencing issues. Symptoms include page timeouts when loading and red error messages when saving.

Our Engineering team is currently assessing the situation. We will update here as information becomes available.

Thank you for your patience.
Posted Mar 23, 2020 - 14:38 UTC
This incident affected: Book Meeting and Personal Scheduling Page.