Login Issues - Application and Dashboard
Incident Report for Cirrus Insight
Resolved
This issue has been resolved.
Posted Aug 18, 2020 - 19:14 UTC
Monitoring
This outstanding login issue has been addressed and a fix deployed. We will continue to monitor the situation and update accordingly.
Thank you for your patience.
Posted Aug 18, 2020 - 18:21 UTC
Identified
We have identified the root of the login issue and are working towards a quick resolution.
Posted Aug 18, 2020 - 17:17 UTC
Investigating
A subset of Cirrus Insight users are currently experiencing issues logging into the Application and Account Management Dashboard. We are aware of the issue and are working towards a resolution.

We apologize for the inconvenience that this may cause.
Posted Aug 18, 2020 - 13:33 UTC
This incident affected: Cirrus Insight Gmail, Cirrus Insight Outlook, and Account Management Dashboard.