Issues logging in to our '23 application and dashboard
Incident Report for Cirrus Insight
Resolved
This issue has been resolved. Please contact our support team at https://www.cirrusinsight.com if you happen to encounter any further complications.
Posted Nov 08, 2023 - 16:11 UTC
Monitoring
A fix has been implemented. The log in and dashboard issues have been resolved. We will continue to monitor.

In the event that you're still experiencing issues, please chat with one of our customer support representatives at www.cirrusinsight.com.
Posted Nov 08, 2023 - 14:02 UTC
Investigating
We are receiving reports of users unable to log into our current application sidebar and account dashboard at home.cirrusinsight.com. This issue is currently being investigated. Updates will be provided as they're available.
Posted Nov 08, 2023 - 13:27 UTC
This incident affected: Cirrus Insight Gmail, Cirrus Insight Outlook, Account Management Dashboard, and cirrusinsight.com.